Visible normal map seams in 3DS Max's viewport

polycounter lvl 4
Offline / Send Message
FourtyNights polycounter lvl 4
Hi, I decided to move to Autodesk's 3DS Max to start rigging my character, from Blender. Just because it's the industry standard and they teach to use it in our school.

Anyway, setting the textures up in Max are giving me problems. Especially very visible seams appear on my normal maps everywhere where there's an UV seam. Also, I don't quite understand the idea of gamma settings when applying textures for your models. Because of those gamma settings, my diffuse isn't that dark as it is seen in this.

Oh, and I used Xoliul viewport shader here. As you can see I didn't go any further with setting up other materials because of this seam issue.

In Blender there are no visible seams and everything (by everything I mean diffuse, normal and specular maps) is looking fine. I baked some of my normal maps in Blender and some in xNormal. And still Blender shows normals correctly regardless where I baked them.

Diffuse and and specular maps seem to work visually fine in Max's viewport, apart from those gamma settings with all of the maps, including normal maps as well.

I have a pretty good and semi-solid knowledge of using Blender, so Max is kinda new to me at the moment. About the character model briefly; I UV unwrapped it so, that certain UV islands are overlapping in the same UV space, but I defined several materials for certain parts of the model to have their unique D/N/S maps. In Blender materials were all clearly separate, but in Max they are under the single main material as sub-materials(?). :D

I've studied a lot of technical stuff about tangent space normals recently, and I read something about the "tangent basis", and somewhere someone mentioned that 3DS Max has some bugs with its viewport shading, etc. I don't know.

So, what could be the problem?

aDvjgeY.jpg

Replies

  • Bartalon
    Offline / Send Message
    Bartalon polycounter lvl 6
    This probably isn't the solution, but it caused a similar issue and might be worth checking anyway: if the normal value is beyond 100 it can cause strange seams and shading issues.
  • FourtyNights
    Offline / Send Message
    FourtyNights polycounter lvl 4
    Max has that adjustable strength value for normal maps with its standard material, yes, but Xoliul doesn't. I tried my normal maps with Max's standard materials too, but no matter what value to use, seams were always visible.
  • Memory
    I don't work with normal maps too often but when I do have seams like this I try these two things:

    Flip the green channel of your normal map (there should be a checkbox somewhere.)

    And switch between world-space or tangent-space for your normal map.

    Hope it helps!
  • petemc
    Offline / Send Message
    petemc polycounter lvl 5
    Make sure your gamma correction is turned off in the scene
  • Mark Dygert
    I'm not sure if Xoliul shader works in newer versions of 3dsmax, they kept changing subtle ways the viewport rendered and I'm not sure if Xoliul was updated? So try sticking to the 3dsmax viewport in realistic mode, I know normal maps will display in that (unless you find something that says Xoliul shader works in your version of max).

    Make sure you aren't just dumping the normal map into the bump slot. You should put a "normal map material type" in the bump slot and then put your actual normal map image in that slot.

    If you did, then its probably like Memory said it's probably that max needs the Green Channel flipped, you can do that in the normal map material type.

    Like Petemc said, Gamma can cause problems too, it gamma correct normal maps throwing off their values causing seams. You can preemptively override the gamma for that image when you select it.

    Gamma%20Override.jpg

    OR you can just turn off Gamma/LUT
    GammaAndLUTPreferances.jpg
  • FourtyNights
    Offline / Send Message
    FourtyNights polycounter lvl 4
    I'm using 3ds Max 2012 and Xoliul viewport shader fully supports that version of Max. I have 2014 version too, but I find 2012 a little bit better.

    And as it reads in Xoliul's support page: "Autodesk has completely broken shading in Max 2013 and 2014. I can not and will not fix this. You should go back to Max 2012 if you want the optimal XS2 experience."

    After I installed Xoliul viewport shader, it automatically disabled the Gamma/LUT Correction settings by giving a pop-up message. I was no longer able to check "Use system default gamma" or "Override". Only "Use image's own gamma".

    So, I enabled it back and tested applying my normals maps with "Override 1.0", and no change - flipped green channel or not as well. Still visible seams.

    With Max's standard material I applied my normal maps just like you said, Mark Dygert. It shows up in the viewport in extreme low resolution and as a colour map, not as a normal map (yeah, I should adjust those viewport bitmap settings for showing textures as high as possible, but I was lazy). So, I rendered it out to see... those seams again. So frustrating. Flipping Red (X), Green (Y), or even "Swap Red & Green" didn't help. :P
  • FourtyNights
    Offline / Send Message
    FourtyNights polycounter lvl 4
    Sorry for the double post but... holy mother of god... I changed the value 2.2 in "Input Gamma" to 1.0 via "Gamma/LUT Correction" settings after reading dozens of threads all around the internet related to this problem, and this solved everything. No seams! :D

    EDIT:

    Here is a bit of a proof of concept. Now it's going to be a pleasure to start the rigging process. ^^

    gy758uY.jpg
Sign In or Register to comment.