Exported Zbrush obj not showing in 3DS Max

polycounter lvl 7
Offline / Send Message
mospheric polycounter lvl 7
Ok, so I'm new to the process of making a base mesh, importing it into Zbrush, sculpting, and then bringing the sculpt into max. I have a friend who does this all the time and he has not had this issue:

I sculpted the high poly in Zbrush. I bring the divisions down and export as .obj. I try to then import the .obj into max, but I get several errors and the mesh never appears.

Errors I get:
"Missing Map - Not found: longhorn_cattle_post_max.bm"

After I select skip, It appears to import and then I get another error...

"OBJ Import Summarys - Diffuse-Map not found in Material: "defaultMat"

Once in Max, the object is selected, but it appears to be super small. Zoom-extents verifies that the object is tiny. Upon scaling up, there is no object to see.

I'm using Zbrush 4.0 and 3DS Max 2011. If other details are needed to help figure out what is wrong, let me know! Thanks for any help!

Replies

  • cryrid
    Offline / Send Message
    cryrid polycounter lvl 7
    When you export the obj from max to zbrush, are you exporting it with a material as well? It almost sounds like it is importing into Max, failing to find a material you defined, and as a result not being visible. You could try giving it a new material in Max after importing, or choosing not to export with a material when you first export the basemesh to zbrush.

    You might also want to try GoZ for Max
  • mospheric
    Offline / Send Message
    mospheric polycounter lvl 7
    Thank you a lot cryid! I probably brought it into Zbrush with a material. I don't know if that was the specific problem, but after setting up GoZ, that seemed to have fixed it! All I did was select GoZ and now it's in my scene! Thanks!
  • Neavah
    I can`t image the problems your having are to do with your missing materials - only for the reason that I also get those messages - and my objects show up (I`m assuming your first missing map is a .bmp)

    At one point with zbrush (3.5) there was really funky stuff going on with importing/exporting models at a reeeaaaly tiny scale. I don't know if its been fixed (?)

    You could always try dropping to your lowest subd in zbrush, store the morph target, then import your base mesh (.obj) again then hit 'switch' and try exporting that... I believe thats worked for me in the past.

    edit: I'm just really slooow at typing - glad its been fixed :)
  • cryrid
    Offline / Send Message
    cryrid polycounter lvl 7
    At one point with zbrush (3.5) there was really funky stuff going on with importing/exporting models at a reeeaaaly tiny scale. I don't know if its been fixed (?)

    My experience with zbrush (from 3.1 onward) has been that it maintains a consistent scale with what it imports; problems with scale would only occur if you export the model wrong from the initial app, or if you apply a scale deformation inside of zbrush.
    Some programs will not show a model in a viewport if it lacks a material. If it has a correct material applied and is just scaled tiny, it should still display (especially when scaled up).
  • Neavah
    At one point with zbrush (3.5) there was really funky stuff going on with importing/exporting models at a reeeaaaly tiny scale. I don't know if its been fixed (?)

    My apologies for being so vague.

    At the time I experienced this issue I found no explanation, only inaccurate, unreliable or tedious scaling solutions, I reverted back to 3.1 and washed my hands clean of the problem.

    Looking further into it, the problem I was describing turns out to be a forward compatibility issue with 3.1 to 3.5.

    Sorry to have mislead anyone :)
Sign In or Register to comment.