Arch asset, problem with normals

PurpleGoop
null
Hello i just registered to polycount to make this post lel.
So i made this simple lowpoly arch on blender for interior purposes in ue4 ( im kinda noob so feel free to point out if the mesh is terribly constructed ) and im getting these artifacts ( second and third image ) to show up with the highpoly normalmap applied. You can clearly see that they follow the triangles on the lowpoly, so is it a problem with the lowpoly itself? I can fix it by brutally adding geometry as if i was making an highpoly out of it, but thats not a good solution at all. 
Any ideas?




Replies

  • somedoggy
    Offline / Send Message
    somedoggy polycounter lvl 5
    you need to be more conservative with your low poly's shading. notice how in the low your normals aren't split anywhere, which makes the entire thing look smooth.



    Doing like the right makes your normal map have to do a ton of work, resulting in the large gradients you see in your texture. Once thrown into an engine this compounds with other potential issues like bit depth, compression, or an unsynced tangent basis.
  • PurpleGoop
    somedoggy said:
    you need to be more conservative with your low poly's shading. notice how in the low your normals aren't split anywhere, which makes the entire thing look smooth.



    Doing like the right makes your normal map have to do a ton of work, resulting in the large gradients you see in your texture. Once thrown into an engine this compounds with other potential issues like bit depth, compression, or an unsynced tangent basis.
    Thanks that helped alot, i never actually used edge split. I now have this weird thing on the split edge but ill probably be able to fix it myself .
    Also for who had my same problem you have to uncheck recompute normals then click apply or the normals will look weird ( look second image )



Sign In or Register to comment.