Noob Question on Texturing with 3DS [Answered]

triangle
Offline / Send Message
Lilium triangle
Hey everyone!

I know my problem must be super basic since I nearly don't know what I'm doing. So I was following a tutorial on Texturing and the guys said to select all polygons to apply Wood texture and then re-select polygons to apply Metal texture. The thing is, I'm able to see and overlap when I click to show shaded material on the viewport. And when I hit render, it's all wood.



I thought that 3DS Max would automatically erase the wood material to replace it with the metal one, but since it doesn't, how can I do it manually?
It's my second time having this particular problem and super-noob-question are not really answered on Google, so I really need your help, please !

Thanks a lot !  :D

UPDATE :
Alright, I was redoing it all and I was playing with the 'Show shaded in viewport' option and hitting Render quite a lot, and.... most of the time my chest is all wood but sometimes it's fine and I've got metal. And I've done nothing more than rendering the same exact thing. What do I not understand..?

Replies

  • Zalek4
    Offline / Send Message
    Zalek4 vertex
    Hi Lilium!

    This is quite interesting, I'm getting a fine result:



    What does the "show shaded material in viewport button look like for you? It should look like this:


    Make sure it is the blue ball, and not the black one on the icon. Make sure the icon is highlighted too. If that doesn't fix it, I have a few questions.

    What does the modifier stack look like for the chest object?
    What renderer are you using? It looks like Scanline but I just want to be sure.
    What does your material editor look like?
  • Lilium
    Offline / Send Message
    Lilium triangle
    Hi!
    Thanks for helping!

    This is what my material editor looks like, and the button looks like yours :

    My modifier stack is simply an edit Poly. Before I had an Unwrap UVW, but I collapse it.
    And yeah I used Scanline, but just to be sure I tried also with Mental Ray and it does the same thing: all wood.
    But your textures doesn't seem to overlap, isn't that why it doesn't work on my end?



  • Zalek4
    Offline / Send Message
    Zalek4 vertex
    Gonna be honest, I didn't even notice that you could see both textures in those areas. The tutorial you linked uses Photoshop to edit the textures before linking them in the material editor right? I would check to see if the opacity on your metal texture is less than 100% inside Photoshop (I can't remember which way the scale goes for it so play around a little). That could be the reason for the wood showing through.

    But that still wouldn't explain it not being in a render.

    Try right clicking on your object and hitting convert>editable poly. This should collapse the whole stack and make "editable poly" the only modifier, rather than having "edit poly".

    Re-apply your materials after you convert it and see if that works. If it doesn't, feel free to link your max file and I'll try to take a better look.
  • Lilium
    Offline / Send Message
    Lilium triangle
    My bad, I had the "editable poly" rather than "edit poly" but just to be sure I did it again me and collapsed everything. It did correct the overlapping by erasing my Metal texture. I try to re-apply it and still the same issue than before :/
    And I checked my Photoshop and no, I'm certain that this is not the issue since my opacity is 100%.

    So since I'm out of option here's my file  with my .psd and the UV mapping (I doubt this will be useful, but I really don't know anymore) :
    https://we.tl/0E1pJwv9j7
    Thanks again for helping me, I'm sure I did something stupid and I'm stuck.

  • Zalek4
    Offline / Send Message
    Zalek4 vertex
    Got it.



    I couldn't have guessed what was wrong in a million years. I'm assuming you're fairly new to Max (no offense intended), since this is quite a unique situation you've created :smile:
    Here's what is going on. Check this picture out:



    All I want you to pay attention to is the list of items on the left hand side starting with "Chest" at the top. If you're new to Max, this is called the Scene Explorer, and you can open it by going to "tools" > "Scene Explorer". I ALWAYS work with this open in order to stay organized, and to avoid situations like this.

    What you've done is duplicated the chest twice on top of itself, which is giving you wonkey results in the renderer. Hence, the "Chest001" and "Chest002" in the Exporer.

    Visually, this:


    Is actually this:


    But all 3 are in the same place as the highlighted chest.

    This is what caused you to get varied results for no apparent reason every time you rendered. You were rendering three overlapping models, and one would show up one time, but another would the next. The models being in the same place would have caused the texture clipping you experienced too (Just for future reference, if the textures flicker on an object when you rotate or move around in your viewport, bad things are afoot, and any variation of this situation is probably the culprit).


    Other than having the models on top of each other, everything else looks great! Great job overall if you're brand new to Max!

    Thanks again for helping me, I'm sure I did something stupid and I'm stuck. 
    Something stupid or not, you learned something and that's all that matters. Mistakes are lessons that make us better at what we do!

    I hope I don't come off as patronizing, and if I do I apologize. Just want to make sure I'm as clear as I can be for ya!

    Hope this helps, just ask if you need any clarification.
  • Lilium
    Offline / Send Message
    Lilium triangle
    OMG. I would never have guessed either ! I'll probably never make that mistake again now that I know it!
    And don't worry, I know I'm new to max since I have non-googleable questions XD  But I'm not that new to 3d modeling in general, so I'll just have to make all the beginner's mistakes and then I'll probably be good !

    Thanks again, now because of you, I can start modeling again!  :D
Sign In or Register to comment.