Weird Seam issues

polycounter
Offline / Send Message
lotet polycounter


and its only visible in Marmo, so Ive kinda just ignored it.

Replies

  • lotet
    Offline / Send Message
    lotet polycounter
    It looks like this btw:

  • EarthQuake
    A couple things:

    Make sure mesh normals are exported from your 3d app (not just smoothing groups)

    Make sure the tangent space is set to the same as where you baked your normal map. You can set the tangent space in the mesh object's properties. You can also set a default tangent space in Edit->Preferences, though this will only apply to newly imported meshes.
  • Jynxia
    Offline / Send Message
    Jynxia polycounter lvl 2
    A couple things:

    Make sure mesh normals are exported from your 3d app (not just smoothing groups)

    Make sure the tangent space is set to the same as where you baked your normal map. You can set the tangent space in the mesh object's properties. You can also set a default tangent space in Edit->Preferences, though this will only apply to newly imported meshes.
    I've also had this problem with my low poly mirrored meshes. I've tried all these options^

    A little more info; this only happened when I upgraded to Marmoset Toolbag 3. It didn't used to happen on TB2.

    In regards to tangent space: Usually I'd use the default xNormal MikkTspace to bake my maps but I've had better results recently with the Unity tangents from: https://farfarer.com/blog/2012/06/12/unity3d-tangent-basis-plugin-xnormal/  
    When exporting I've made sure to set the tangent space to Unity 5(old) or Marmoset.
    Here's some examples:




    The models are pretty low poly; about 1500 tris each. Only using a diffuse, spec and normal map. I've isolated the maps and the prob is definitely with the normal map.

    also, Lotet- I feel your pain man. Mirrored seams are a pain in the butt.

    Any help appreciated! 
    Jo
  • Jynxia
    Offline / Send Message
    Jynxia polycounter lvl 2
    and just to check further, here she is in unity using the default settings: 
    so it's defo a setting in Marmoset I'm looking for
  • lotet
    Offline / Send Message
    lotet polycounter
    yep, definitely looks like the same issue Im having :(
  • EarthQuake
    Hey guys, can you send me your models/scenes so I can have a look? Easiest way is to go to File -> Export -> Scene Bundle, and zip up the .tbscene and /assets/ folder.
  • michaelmoures
    i think this could help ... yes this artifact happens when you have overlaped uvs island so u can solve it by

    1- make sure that u gave every uvs island a diffrent( smoothing group or phonge break) even if they are have  overlaping uvs.
    2- export normals of the low poly mesh from the applicaton (object with normals )
    3- make sure u added enough edge padding to your uvs.
    4-make sure u dont have fliped uvs while ur ovelaping them.
    5- when u baking make sure that the heigh poly is full model and the low poly is full model with normals . and then bake. these is important and can cause normal proplems like these ones

    note : if the normals is right... it renders right in any applicaton .its not the applicaton proplem.

    if it didnt work try not to overlap the uvs ...i know this is stupid option and doesnt save uv space but at least u can know if the uv overlaping is the proplem

    i hope that is helpfull and solve your proplem. and reply if it works


  • Jynxia
    Offline / Send Message
    Jynxia polycounter lvl 2
    i think this could help ... yes this artifact happens when you have overlaped uvs island so u can solve it by

    1- make sure that u gave every uvs island a diffrent( smoothing group or phonge break) even if they are have  overlaping uvs.
    2- export normals of the low poly mesh from the applicaton (object with normals )
    3- make sure u added enough edge padding to your uvs.
    4-make sure u dont have fliped uvs while ur ovelaping them.
    5- when u baking make sure that the heigh poly is full model and the low poly is full model with normals . and then bake. these is important and can cause normal proplems like these ones

    note : if the normals is right... it renders right in any applicaton .its not the applicaton proplem.

    if it didnt work try not to overlap the uvs ...i know this is stupid option and doesnt save uv space but at least u can know if the uv overlaping is the proplem

    i hope that is helpfull and solve your proplem. and reply if it works


    I've not heard of this solution before, thanks MichealMoures! I'll experiment with this next time I'm baking :)

    EarthQuake & Lotet, I found that my problem was resolved by choosing MikkTspace in tangent settings, then choosing a different setting (like unity, marmoset ect). It looks like it corrects the problem, then when you choose whatever tangent setting you need, the weird seams are still gone. I had to do this every time I imported a mesh but it worked for me!

    I hope this helps
Sign In or Register to comment.