DDO PS 2015 Metallic workflow completely broken

polycounter lvl 2
Offline / Send Message
echofourpapa polycounter lvl 2
Hi,

Has anyone else been able to use DDO and Photoshop CC 2015 with a metallic workflow? I have not been able to get DDO to work for metallic materials.

The problem is that the pattern overlay layer style is not being set correctly, or at all in some cases. I've been able to get a single material/smart material to add in correctly, but after that no other layer style if it has a pattern overlay is applied to any of the maps.

Curiously, specular setups work just fine.

Is this a known issue, or perhaps related to the recent changes in PS's layer styles?

Any help would be greatly appreciated!

Replies

  • Framedworld
    Offline / Send Message
    Framedworld triangle
    are we talking metallic as in UE4 or simply metalness? Our team is using a metalness workflow to a lot of success. I mean its the same thing, but "metallic" maps is from the UE4 exporter option so it might have something to do with that.
  • echofourpapa
    Offline / Send Message
    echofourpapa polycounter lvl 2
    Sorry, yes metalness. I've been using it for a while but after the PS CC 2015 update I began to have this problem. I'm using Unity 5 Metalness calibration.
  • Wiktor
    Offline / Send Message
    Wiktor polycounter lvl 8
    Does this problem only occur when using a metalness profile? Also, which one in specific are you working with? If this only occurs for metalness projects I doubt it's because of the PS CC 2015 update.
  • echofourpapa
    Offline / Send Message
    echofourpapa polycounter lvl 2
    Yes, it only occurs when using a metalness profile. I am using the Unity 5 (Metalness) profile.

    This only started happening after the PS 2015 update. There is also another interesting symptom, if I select the layer for that material that should have layer style and a pattern overlay and manually add a layer style it gives what looks like one of the last setting that DDO tried to put on the layer. I'm going to take some screenshots and put together some steps to repo this problem.

    I have a team of 6 all with Quixel 1.8 + Patches and PS CC 2015, and everyone is experiencing this problem currently.
  • echofourpapa
    Offline / Send Message
    echofourpapa polycounter lvl 2
    here's the steps:

    Step one: create a project: Step1.PNG

    Now I've got a clean project:
    Step2.PNG

    I add in a material or smart material:
    Step3.PNG

    The asset looks fine, everything seems to be working:
    Step4.PNG

    Now if I try to add any other material:
    Step6.PNG

    Something goes wrong and layer patterns stop being added:
    Step7.PNG

    Try adding another material:
    Step5.PNG

    Doesn't add in any new patterns(even though the layer style is present):
    Step8.PNG

    When opening up the layer style this happens:
    Step9.PNG

    I'm pretty sure that's not the right pattern for this map.
  • Wiktor
    Offline / Send Message
    Wiktor polycounter lvl 8
    Thank you very much for the detailed repro! We'll take a look at this and get back to you. :)
  • RezNik
    Offline / Send Message
    RezNik triangle
    I've been getting the same exact thing since moving to Photoshop CC 2015. I use a custom dull steel, but every other smart material that I have tried does the same. Its always the first one that works as expected then after that every smart mat masks incorrectly. Im using the Unity 5 metalness workflow as well.

    Repro:
    -Input maps: id, normal map, ambient occlusion, object space
    -Click generate
    -add smart mat... mask turns out as expected
    -Add another smart mat... masking is bad

    masking_issues.jpg
    photo hosting
  • RezNik
    Offline / Send Message
    RezNik triangle
    Kinda found a work around for this.

    -I went with the unity5 specularity workflow.
    -Made my materials like normal
    -Then I added the Metallic and albedo(metalness) maps.
    -Then I deleted the spec and albedo (wouldn't export correctly before this step).

    Not optimal but gets me back on track to the 50+ items I need to make.
  • MrLeighHall
    Question... did you delete the spec map straight after starting up the project or did you delete spec map once you added all the materials
  • echofourpapa
    Offline / Send Message
    echofourpapa polycounter lvl 2
    I did all my work in spec and then add in then add in the metalness map. I find that I can't add in Albedo For Metalness all the time, because it still doesn't create the materials correctly. The Metalness map works well enough(since it's just black and white). I was actually going back in and compositing the diffuse and specular albedo maps into one metalness albedo map, but that's proved to be too time consuming.

    I've ended up abandoning metalness altogether and I'm only using specular now.
Sign In or Register to comment.