Collsion Mesh Issues

polycounter lvl 7
Offline / Send Message
dang87 polycounter lvl 7
So I have a static mesh with a collision mesh set up as my ground/blocking of my level. At the playerStart spawn point, all if fine thus far. No issues, no errors.
Nadir_UDK_Errors001.jpg


Continuing on, I go up a slope with no issues at all.
Nadir_UDK_Errors002.jpg


Then when I get tot he area I'm planning to be a town square, I get blocked and cant go further to the other areas I want to go to, liek a wall has been place there although the collision mesh show no such thing there..
Nadir_UDK_Errors003.jpg


Then next issue that come to hand is when trying to climb up higher on another slope. When I try to head up, I fall through the floor.
Nadir_UDK_Errors004.jpg

These blocks were separate blocks at one point in 3DS Max and later just attached without welding. Don't know if that could be an issue or not.
Here are the mesh property stats:
Nadir_UDK_Errors005.jpg

Any help and suggestions are welcomed. Thanks! smile.png

Replies

  • blankslatejoe
    Offline / Send Message
    blankslatejoe polycounter lvl 12
    Hm...it's hard to tell what's going on. For the falling through the mesh problem---try adding more cuts/verts to the problem areas to see if it's a precision problem. If you're working in an area reaaaaaaally far from the world origin, or if you're working with all one mesh, or if you're working at a scale smaller than Unreal expects, I could see there being precision problems.
    As for the invisible wall--yes, not welding could very well cause the invisible wall problem if the verts are juuuuust slightly misaligned. Add that problem to Max's own precision snapping issues and you have a recipe for situations like this. Pretend those misaligned verts are very very tiny stairsteps: if the slope of that step is 45 degrees (or was it 30 degrees..I can't remember), or less, you can walk up it. If it's a perfect vertical step, then Unreal will try and 'pop' the mesh up if it's under a certain threshold distance (called the 'stepupheight' iirc). If the slope is basically anything OTHER that perfect 90 degrees or less than 45, you'll get hung...so try welding the verts and see what you get.
  • Santewi
    Open the mesh in the mesh editor and enable "show collision". If the collision is wrong, you can just recalculate it inside UDK.
  • dang87
    Offline / Send Message
    dang87 polycounter lvl 7
    Found a mesh that has collision mesh issues that was causing the problem. Thanks everyone! :D
Sign In or Register to comment.